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1. Foreword 
SlideShow is a product from signotec GmbH and is used to load images into the signature device 
for presentation on the display. The product comprises two applications: firstly, SlideShow-
Manager, which enables you to configure a slideshow and transfer it to the locally attached 
signature devices; and secondly, SlideShow-Client, which enables automatic transfer of the 
centrally stored configuration to the signature devices in a client-server environment. The following 
sections will describe these applications in more detail. 

2. Requirements 
The system and software requirements are described below. 

2.1. Operating systems 
SlideShow can run on the following operating systems: 

 32-bit 64-bit 

Windows XP X X 

Windows Vista X X 

Windows 7 √ √ 

Windows 8/8.1 √ √ 

Windows 10 √ √ 

Since Microsoft has ended official support for Windows XP (on April 8th 2014) and 
Windows Vista (on April 11th 2017), we can no longer provide support for these operating 
systems. 

2.2. .NET Framework 
SlideShow-Manager requires the Microsoft .NET Framework 4.0 Client Profile. If this package is not 
on your system, it will be installed automatically from the Internet. Alternatively, you can download 
the Framework from the Internet beforehand. Go to download page. 

2.3. Dependencies 
For communication with the signature devices, SlideShow requires Microsoft Foundation Classes 
(MFC) 10. If this package is not on your system, it will be installed automatically from the Internet. 
Alternatively, you can download the runtimes from the Internet beforehand. Go to download page 
(x86). Go to download page (x64). 

  

https://www.microsoft.com/en-gb/download/details.aspx?id=24872
https://www.microsoft.com/en-gb/download/details.aspx?id=5555
https://www.microsoft.com/en-gb/download/details.aspx?id=5555
https://www.microsoft.com/en-gb/download/details.aspx?id=14632
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3. Installation 
The possible installation options are described below. 

3.1. Standard installation 
Please run the signotec_SlideShow_X.X.X.exe setup as an administrator. If you have activated 
User Account Control, confirm the following prompt by clicking Yes. 

After confirmation, the installation will be prepared and you will be shown a welcome screen. 
Please click Next >. 

The licensing agreement then appears. Please read it carefully and confirm by selecting I accept 
the terms in the licensing agreement. Please click Next >. 

In the next step, you can change the storage location for the installation files. To do this, click 
Change.... A new window opens to allow you to change the folder. If you are satisfied with the 
installation location, click Next >. 

Now you can specify the type of installation. Select Complete if you wish to install both 
programme components; by selecting Custom, you can choose to install only the SlideShow-
Manager or only the SlideShow-Client. Once you have made your selection, click Next >. 

If you selected Custom, you can now exclude individual components from the installation or add 
them again. For a detailed description of how to exclude components from the installation or add 
them again, click the Help button. Afterwards, please click Next >. 

Then, all you need to do is start the installation. To do this, click Install. 

Click Finish to complete the installation. 

3.2. Silent installation 
You can also perform the installation without user interaction. To do so, launch the command 
prompt (cmd) as an administrator and run the following command: 

"Path\signotec_SlideShow_X.X.X.exe” /s /v" INSTALLDIR=\"C:\Program Files (x86)\signotec\" /qn" 

If only the SlideShowManager or only the SlideShowClient shall be installed, this can be defined by 
ADDLOCAL. Please pay attention to the upper and lower case of the feature names. 

"Path\signotec_SlideShow_X.X.X.exe” /s /v" INSTALLDIR=\"C:\Program Files (x86)\signotec\" 
ADDLOCAL=SlideShowManager /qn" 

"Path\signotec_SlideShow_X.X.X.exe” /s /v" INSTALLDIR=\"C:\Program Files (x86)\signotec\" 
ADDLOCAL=SlideShowClient /qn" 

After the installation has been successfully completed, you can close the command prompt. 
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4. SlideShow-Manager 
The SlideShow-Manager allows you to configure and load images for presentation on the signature 
device’s display. These images are saved to the internal memory of the signature device, whereby 
the SlideShow product does not have to be installed on the computer for their display. The images 
are displayed solely in standby mode of the signature device. A slideshow can be configured for the 
Omega, Alpha, Gamma and Delta signature devices; merely an image (background image) can be 
defined for the Sigma and Zeta device. The connection types supported are HID, WinUSB, COM and 
IP. The configuration can be loaded directly onto the attached signature devices. Alternatively, it 
can be stored on a server and subsequently transferred to the signature devices using SlideShow-
Client. 

 

4.1. Menu bar 
In the menu bar, you can select File > Exit to exit the SlideShow-Manager application without 
saving your changes and without receiving a prompt. 

By selecting Help > Open documentation… or pressing the F1 function key, you can open the 
documentation in a separate window. 

By selecting Help > About signotec SlideShow-Manager… you can display further information 
such as contact data or version number. 
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4.2. SlideShow-Configuration 
In the ‘SlideShow-Configuration’ section, you can carry out the configuration for the individual 
signature devices. To do so, please select the tab of the relevant signature device and then specify 
the settings. You can configure several signature devices before transferring the configuration to 
the respective signature device. 

Due to the different image memories, the number of images that can be configured for each 
signature device is different. 

Signature 
device 

Number of 
images 

Sigma 1 

Zeta 1 

Omega 10 

Alpha 10 

Gamma 10 

Delta 31 

Load Image… allows you to select an image file using an Open dialog box. After selecting an 
image file, confirm by clicking the Open button. All common image formats such as .bmp, .jpg, 
.gif, .png and .tif are supported. Please ensure that the resolution of the image is in accordance 
with the resolution of the signature device. 

Signature 
device Resolution 

Sigma 320 x 160 px 

Zeta 320 x 200 px 

Omega 640 x 480 px 

Alpha 768 x 1366 px 

Gamma 800 x 480 px 

Delta 1280 x 800 px 

The image you have selected is shown in the preview window. 

 

The Individual display duration check box allows you to specify whether the image should have 
its own display duration or whether the general interval should be used. If you enable this setting, 
the input field beneath it is enabled and you must enter the value in seconds. The value 1 is 
entered by default. The value can lie between 1 and 255 or 1 and 300, depending on the signature 
device. If you disable this setting, the value entered in the Display duration: field will take effect. 
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You can use the drop-down list with the entries One-time, Enduring and End up to define when 
the image should be displayed. 

• If One-time is selected, the transferred image is displayed only once in the slideshow, and 
then no more. Only when you disconnect the power supply to the signature device and 
then reconnect it, or close an active connection to the signature device (end signature 
process), is the image displayed again (on a one-time basis). 

• If Enduring is selected, the image is always displayed in the slideshow. 
• If End up is selected, the image is displayed, after which the slideshow is ended and the 

display switches off. Only when you disconnect the power supply to the signature device 
and then reconnect it, or close an active connection to the signature device (end signature 
process), does the slideshow restart before it is ended again after display of this image. 

Please note, that the advanced settings (Individual display duration and the options 
One-time and End up) are only supported by the Omega since revision M or M-N. For 
older revisions you will be asked, if you want to ignore these settings before 
transferring. If yes, the option Enduring and the general display duration will be used, 
if no, the configuration won’t be transferred. The Alpha doesn’t support the advanced 
settings, so they aren’t configurable and always the option Enduring and the general 
display duration will be used. 

The Discard button allows you to delete your defined settings without receiving a prompt. 

Lastly, you can use the Display duration: field to define the display duration for all images for 
which ‘Individual display duration’ was not enabled. The value must be likewise specified in 
seconds and lie between 1 and 255 or 1 and 300, depending on the signature device. The value 1 
is entered by default. 

Please observe the following possible intervals for the signature devices. 

Signature 
device Interval 

Sigma - 

Omega Up to 300 

Alpha Up to 300 

Gamma Up to 255 

Delta Up to 255 
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4.3. Transfer SlideShow to signature pads 
In the ‘Transfer SlideShow to signature pads’ section, you can transfer the configuration to the 
signature devices. 

First, use the list box to select the relevant connection type (USB Devices, VCOM Devices, USB 
and VCOM Devices or IP Devices). 

• If USB Devices is selected, the configuration is transferred to all signature devices that are 
connected via USB (HID or WinUSB). 

• If VCOM Devices is selected, the configuration is transferred to all signature devices that 
are connected via COM (FTDI or Virtual COM Port driver). 

• If USB and VCOM Devices is selected, the configuration is transferred to all signature 
devices that are connected via USB or COM. 

• If IP Devices is selected, the configuration is transferred to the signature device according 
to the set IP address and port. If the IP address space is also configured, the 
configuration is transferred to all signature devices that are located in the defined IP range. 

By clicking the Transfer SlideShow button, you can start the transfer of the configuration to the 
signature devices. 

Information about the signature device to which the configuration is currently being transferred is 
shown under Device type, Firmware, Serial number and Connection. 
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4.4. Transfer SlideShow configuration to server 
In the ‘Transfer SlideShow configuration to server’ section, you can store the configuration on a 
server, which is later accessed using SlideShow-Client, in order to transfer the images to the 
signature device. 

You use the Configure server access… button to define the directory in which the configuration 
is to be stored. 

• If this is to happen via the Network Drive option, please select this accordingly. You can 
then enter the path manually under Directory, or click the button with the three dots to 
specify the directory using a dialog box. 

• If this is to happen via the UNC path option, please select this accordingly. You can then 
enter the path manually under Directory, or click the button with the three dots to specify 
the directory using a dialog box. In addition, you must enter login details for the user who 
has write access to the defined directory (under User’s name and User’s password). 

Finally, you confirm the configuration with OK or discard your changes using Cancel. After you have 
clicked OK, the system performs a brief check of the defined directory with the entered login data. If 
this fails, you will be informed via a warning. If the check is successful, you will receive information 
on the next steps to be taken. 

Lastly, you must of course transfer the configuration to the server by clicking the Upload 
configuration button. There, you will then find the following folders and files. 

Folder/file Explanation 

AlphaDirectory Contains all configured images for the Alpha 

DeltaDirectory Contains all configured images for the Delta 

GammaDirectory Contains all configured images for the Gamma 

OmegaDirectory Contains all configured images for the Omega 

SigmaDirectory Contains the configured image for the Sigma 

ClientSettings.xml Contains the information for the server access 

RemoteSettings.xml Contains the configuration for all signature devices and a timestamp 
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5. SlideShow-Client 
The SlideShow-Client allows you to load images for presentation on the signature device’s display 
that were configured beforehand using the SlideShow-Manager and stored centrally on a server. By 
using the SlideShow-Client, the slideshow does not have to be transferred manually to the attached 
signature devices using SlideShow-Manager; rather, the procedure can be carried out fully 
automatically. You might want to use this option to minimise the amount of effort required if you 
have a lot of signature devices in use and the slideshow frequently changes. 

5.1. Transfer configuration 
The first thing you must do is copy the ClientSettings.xml file from the configuration that you 
have loaded onto the server using SlideShow-Manager, and swap it with the local 
ClientSettings.xml file from the installation directory …\SlideShow\SlideShowClient\. 

You should now create a shortcut in the ‘Startup’ (autostart) folder to the 
SlideShowClient_x86.cmd or SlideShowClient_x64.cmd file (depending on the operating 
system) from the installation directory …\SlideShow\SlideShowClient\. This file contains the 
call to the SlideShowClient.exe file, which does not have a user interface. The shortcut in the 
‘Startup’ folder ensures that a check is performed on user login, to determine whether the 
configuration must be transferred to the signature devices. Alternatively, you can start this process 
at any other time by running the SlideShowClient.exe file. 

After the SlideShow-Client has been run, it checks whether the UserSettings.xml file is present in 
the directory %APPDATA%\signotec\SlideShowClient. 

• If the file is not present, the SlideShow-Client uses the data stored in the 
ClientSettings.xml file to connect to the server, from where it loads the configuration and 
images and transfers them to the attached signature devices. 

• If the file is present, the SlideShow-Client checks whether the timestamp in the 
UserSettings.xml file matches that in the RemoteSettings.xml file on the server, and 
whether the serial numbers in the UserSettings.xml file matches that of the attached 
signature devices. 

• If the timestamp or serial numbers does not match, the configuration on the server 
was changed or the attached signature devices have changed. As a result, the 
SlideShow-Client connects to the server and transfers the configuration and images 
to the attached signature devices. 

• If the timestamp and serial numbers match, the configuration on the server was 
not changed, nor have the attached signature devices changed. There is no action 
on the part of the SlideShow-Client. 

If the transfer was successfully completed, the UserSettings.xml is created or changed in the 
directory specified above, and receives the timestamp of the RemoteSettings.xml file from the 
server. 

Please note, that the advanced settings (Individual display duration and the options 
One-time and End up) are only supported by the Omega since revision M or M-N. The 
Alpha doesn’t support the advanced settings. Upon transfer these settings will be 
ignored and always the option Enduring and the general display duration will be used. 
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If the directory on the server or the access data changes, you must upload the configuration again 
using SlideShow-Manager and then distribute the ClientSettings.xml file to the local computers. 

If the configuration or the images change, you merely have to upload the configuration again using 
SlideShow-Manager. As a result, the timestamp in the RemoteSettings.xml file is changed and the 
transfer is started when the next check is carried out by the SlideShow-Client. Should a 
configuration and images already exist on the signature device, they are overwritten. 

5.2. SlideShowClient.ini 
You can make two configuration settings using the SlideShowClient.ini file in the installation 
directory …\SlideShow\SlideShowClient\. 

If, contrary to expectations, problems occur during the transfer with the SlideShow-Client, you can 
use the Logging=YES entry to enable the logging of detailed information. You will then find the 
log in the directory %USERPROFILE% with the name SlideShowClient-Date.log. 

In addition, you can use the SearchAllFTDIAgain=YES entry to define whether the SlideShow-
Client should search on all COM ports for available signature devices, or only for those stored in the 
UserSettings.xml file. If the COM ports of the signature devices have changed or further ones have 
been added, a search for all COM ports should be carried out, as otherwise signature devices will 
be omitted. However, the transfer will then take longer, as all COM ports are checked first, to 
determine whether a signature device is attached. 
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